Strayer Logo
Potential iCampus Services Interruption
Incident Report for Strayer University
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 12:27 EST
Investigating
Service disruptions have been detected on the Strayer iCampus.

Users may encounter issues throughout the platform, which could include intermittent access to iCampus.

Other iCampus services may also be impacted.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Jan 13, 2020 - 12:25 EST