Strayer Logo
Potential Blackboard Services Interruption
Incident Report for Strayer University
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 11:39 EST
Investigating
Service disruptions have been detected for Strayer Blackboard.

Users may encounter issues throughout the platform, which could include intermittent access to Blackboard.

Other Blackboard services may also be impacted.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Nov 23, 2020 - 11:20 EST
This incident affected: Blackboard.