Strayer Logo
Potential Blackboard Services Interruption
Incident Report for Strayer University
Resolved
This incident has been resolved.
Posted Jul 08, 2023 - 23:48 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 08, 2023 - 20:41 EDT
Investigating
Service disruptions have been detected for Strayer Blackboard and other services.

Users may encounter issues throughout the platform, which could include intermittent access to Blackboard, iCampus and portions of Canvas.

Other services may also be impacted.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Jul 07, 2023 - 11:47 EDT
This incident affected: iCampus (Main Site) and Canvas.