Strayer Logo
Potential Login Services Interruption
Incident Report for Strayer University
Resolved
This incident has been resolved.
Posted Jan 01, 2024 - 12:39 EST
Investigating
Service disruptions have been detected on the Strayer Login Services.

Users may encounter issues throughout the platform, which could include intermittent access to several Strayer Systems due to a network-related issue.

This issue is under investigation. Please monitor this Status Page for updates.
Posted Jan 01, 2024 - 12:34 EST
This incident affected: Login Services.