Strayer Logo
SU Regent Student Experience Portal issues
Incident Report for Strayer University
Resolved
This incident has been resolved.
Posted May 01, 2023 - 17:04 EDT
Monitoring
SU Regent has recovered, we are continuing to monitor.
Posted May 01, 2023 - 16:18 EDT
Investigating
We are currently investigating the issue.
Posted May 01, 2023 - 16:05 EDT