Strayer Logo
Potential Login Services Interruption
Incident Report for Strayer University
Resolved
This incident has been resolved.
Posted Aug 01, 2019 - 14:18 EDT
Investigating
Service disruptions have been detected on the Strayer Login Services.

Users may encounter issues throughout the platform, which could include intermittent access to several Strayer Systems.


This issue is under investigation. Please monitor this Status Page for updates.
Posted Aug 01, 2019 - 13:53 EDT
This incident affected: Login Services.